re = /[^:,\n]+:.*?(?=,(?:\w|$))/m
str = 'active site: His, Glu,region: nucleotide-binding motif A,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end