import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/\\*.*?\\*\\/|\\/\\/.*?\\n)";
final String string = "class TypeInfo;\n\n"
+ "TURBO_CLASS() //uywefbcgfwbcrgbycbcuynuyb\n"
+ "class TestClass : private Test, public TestTest, protected BaseClass\n"
+ "{\n"
+ " TURBO_CLASS_H_GENERATION()\n\n"
+ " private:\n"
+ " TestClass * tc;\n"
+ "/* test iulghrenc liuerhgnceyjrgbh */\n"
+ " TURBO_PROPERTY()\n"
+ " std::string var1 = \"Default\" ; //Reflected\n\n"
+ " TURBO_PROPERTY()\n"
+ " int var2 = 2; //Reflected\n\n"
+ " TestClass* tc2;\n\n"
+ " TURBO_PROPERTY()\n"
+ " int var3 = 3; //Reflected\n\n"
+ " public:\n"
+ " TestClass() = default;\n"
+ " TestClass(std::string&& s, int i, int i2);\n"
+ "};\n\n"
+ "TURBO_CLASS() //uywefbcgfwbcrgbycbcuynuyb\n"
+ "class TestClass2 : private Test, /*test lol */public TestTest, protected BaseClass\n"
+ "{\n"
+ " TURBO_CLASS_H_GENERATION()\n\n"
+ "/*\n"
+ " Test\n"
+ "*/\n\n"
+ " private:\n"
+ " TestClass * tc;\n\n"
+ " TURBO_PROPERTY()\n"
+ " std::string var1 = \"Default\" ; //Reflected\n\n"
+ " TURBO_PROPERTY()\n"
+ " int var2 = 2; //Reflected\n\n"
+ " TestClass* tc2;\n\n"
+ " TURBO_PROPERTY()\n"
+ " int var3 = 3; //Reflected\n\n"
+ " public:\n"
+ " TestClass() = default;\n"
+ " TestClass(std::string&& s, int i, int i2);\n"
+ "};\n\n\n"
+ "#endif";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}