const regex = /(\/\*.*?\*\/|\/\/.*?\n)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/\\*.*?\\*\\\/|\\\/\\\/.*?\\n)', 'gm')
const str = `class TypeInfo;
TURBO_CLASS() //uywefbcgfwbcrgbycbcuynuyb
class TestClass : private Test, public TestTest, protected BaseClass
{
TURBO_CLASS_H_GENERATION()
private:
TestClass * tc;
/* test iulghrenc liuerhgnceyjrgbh */
TURBO_PROPERTY()
std::string var1 = "Default" ; //Reflected
TURBO_PROPERTY()
int var2 = 2; //Reflected
TestClass* tc2;
TURBO_PROPERTY()
int var3 = 3; //Reflected
public:
TestClass() = default;
TestClass(std::string&& s, int i, int i2);
};
TURBO_CLASS() //uywefbcgfwbcrgbycbcuynuyb
class TestClass2 : private Test, /*test lol */public TestTest, protected BaseClass
{
TURBO_CLASS_H_GENERATION()
/*
Test
*/
private:
TestClass * tc;
TURBO_PROPERTY()
std::string var1 = "Default" ; //Reflected
TURBO_PROPERTY()
int var2 = 2; //Reflected
TestClass* tc2;
TURBO_PROPERTY()
int var3 = 3; //Reflected
public:
TestClass() = default;
TestClass(std::string&& s, int i, int i2);
};
#endif`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);