$re = '/\[(-?\d+)\]/m';
$str = '[-1] category -1
[1] category 1
[11] category 11
[123] category 123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);