re = /\[(-?\d+)\]/m
str = '[-1] category -1
[1] category 1
[11] category 11
[123] category 123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end