import Foundation
let pattern = #"[a-zA-z\-]+( )+?=( )+?(:id)( +)?and|and( +)?[a-zA-z\-]+( )+?=( )+?(:id)$|where( )+?[a-zA-z\-]+( )+?=( )+?(:id)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
id = :id
id = id
SELECT * FROM A ID IN (select ID from users where id_ec = :id)
select * from users where id = :id and name = :name
select * from users where name = :name and id = :id aNd name = :name
select * from users where name = :name and name = :name and id = :id
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)