use strict;
my $str = '123abc
assass
abc
abc-abc.
abc-123.
123-abc.
abc123
abc.
abc'n com 123
abc 123 abc.123
www.abc.
abc.com
www.abc
www.abc.com
abc-foo
what.com abc is the place to abc. <-- That last abc should be highlighted.
what.com abc is the place to abc. That last abc should be highlighted.
www.abc. Foo bar
look
looking
tearsofsteel
www.tearsofsteel
www.tearsofsteel.org
www.Nleader.org
www3
www3we
www
www.
you\'re
Juggling.com
jugg';
my $regex = qr/(\b(?<![[:punct:]])abc'n(?![[:punct:]])\b)/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}