import Foundation
let pattern = #"(\b(?<![[:punct:]])abc'n(?![[:punct:]])\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
123abc
assass
abc
abc-abc.
abc-123.
123-abc.
abc123
abc.
abc'n com 123
abc 123 abc.123
www.abc.
abc.com
www.abc
www.abc.com
abc-foo
what.com abc is the place to abc. <-- That last abc should be highlighted.
what.com abc is the place to abc. That last abc should be highlighted.
www.abc. Foo bar
look
looking
tearsofsteel
www.tearsofsteel
www.tearsofsteel.org
www.Nleader.org
www3
www3we
www
www.
you're
Juggling.com
jugg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)