package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(?:\s|^)((?:https?:\/\/)?(?:[a-z0-9-]+(?:\.[a-z0-9-]+)+)(?::[0-9]+)?(?:\/(?:[^\s]+)?)?)`)
var str = `test
example.com
www.example.com
test sub.example.com test
http://example.com
test http://www.example.com test
http://sub.example.com
https://example.com
https://www.example.com
https://sub.example.com
http://sub.example.com:123/test/test?asd=123&asd=123
http://super1domain-asd.com/
test example@example.com <- i don't want to match this
example@example.co.uk <- i don't want to match this
git://github.com/user/project-name.git
irc://irc.undernet.org:6667/mIRC jhasbdjkbasd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}