const regex = /(?:\s|^)((?:https?:\/\/)?(?:[a-z0-9-]+(?:\.[a-z0-9-]+)+)(?::[0-9]+)?(?:\/(?:[^\s]+)?)?)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s|^)((?:https?:\\\/\\\/)?(?:[a-z0-9-]+(?:\\.[a-z0-9-]+)+)(?::[0-9]+)?(?:\\\/(?:[^\\s]+)?)?)', 'gim')
const str = `test
example.com
www.example.com
test sub.example.com test
http://example.com
test http://www.example.com test
http://sub.example.com
https://example.com
https://www.example.com
https://sub.example.com
http://sub.example.com:123/test/test?asd=123&asd=123
http://super1domain-asd.com/
test example@example.com <- i don't want to match this
example@example.co.uk <- i don't want to match this
git://github.com/user/project-name.git
irc://irc.undernet.org:6667/mIRC jhasbdjkbasd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}