#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?=.*building)(?=.*boat).*"
Local $sString = "Corporate" & @CRLF & _
"Exporters" & @CRLF & _
"Buyers" & @CRLF & _
"News" & @CRLF & _
"Apparel" & @CRLF & _
"Aquarium Fish" & @CRLF & _
"Boat and Ship Building"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")