$re = '/^(?=.*building)(?=.*boat).*/im';
$str = 'Corporate
Exporters
Buyers
News
Apparel
Aquarium Fish
Boat and Ship Building';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);