use strict;
my $str = '12345678.11111111111';
my $regex = qr/(?<=\d)(?=(?:\d{3})+\.)/mp;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";