$re = '/(?<=\d)(?=(?:\d{3})+\.)/m';
$str = '12345678.11111111111';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;