$re = '/https://website/\d+/\w+/';
$str = 'https://website/1/extension1
https://website/1.1/extension1
https://website/1/#extension1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);