re = /https:\/\/website\/\d+\/\w+/
str = 'https://website/1/extension1
https://website/1.1/extension1
https://website/1/#extension1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end