re = /(?>(?!\A)\G|[^<]*+<a\b(?>[^>]*?\bhref=)["'])[^"'-]*+\K-|[^>]*+>(*SKIP)(*FAIL)/m
str = '<div id="breadcrumb-section">
<ol id="breadcrumbs">
<li class="first">
<span>
<a href="index.html">Technologies</a>
</span>
</li>
<li>
<span>
<a href="Some-Technologies-Documentation_218464400.html">Some Technologies Documentation</a>
</span>
</li>
<li>
<span>
<a href="Some-Other-Documentation_268370090.html">Some Other Documentation</a>
</span>
</li>
<li>
<span>
<a href="Another-Documentation_268370112.html">Another Documentation</a>
</span>
</li>
</ol>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end