using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"BR($|-)";
string input = @"2544631BR-I
2544631BR
BR124DR-I
2548061DR";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}