$re = '/BR($|-)/m';
$str = '2544631BR-I
2544631BR
BR124DR-I
2548061DR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);