re = /([\w:*=.#-\s\[\]]+(?!([^\[\{]*[\]\}@])))/
str = 'body {background:crimson;overflow:hidden}[id*=xat],hr,table{display:none}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end