$re = '/\`(?:.|\`)*\`/';
$str = 'this is `a string {eval this} with {and that} inside` asd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);