re = /\`(?:.|\`)*\`/
str = 'this is `a string {eval this} with {and that} inside` asd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end