using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?:errorMessage|ERRORTEXT|Error_Messages)>([^<>]+)</(?:errorMessage|ERRORTEXT|Error_Messages)>";
string input = @" <?xml version=""1.0"" endcoding=UTF-8""?>
<n0:szemelyKutyaFuleResponsexmlns:prx=""urn:sap.comproxy:SWP:/1SAI/TREASE1243804269AE457508F4:753"" mmlns:n0=""http://csajgeneratorws.tny.interfesz.kok.lo/"">
<return>
<tanzakciosAzonosito>46981682-4637-49d2-bd4d-dcfff543742ed</tanzakciosAzonosito>
<erdmeny>HIBAS</eredmeny>
<errorCode>TSH08</errorCode>
<errorMessage>Azonosítószám már hozzá lett rendelve üzleti partnerhez</errorMessage>
</return>
</n0:szemelyKutyaFuleResponse>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}