import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?:errorMessage|ERRORTEXT|Error_Messages)>([^<>]+)</(?:errorMessage|ERRORTEXT|Error_Messages)>";
final String string = " <?xml version=\"1.0\" endcoding=UTF-8\"?>\n"
+ " <n0:szemelyKutyaFuleResponsexmlns:prx=\"urn:sap.comproxy:SWP:/1SAI/TREASE1243804269AE457508F4:753\" mmlns:n0=\"http://csajgeneratorws.tny.interfesz.kok.lo/\">\n"
+ " <return>\n"
+ " <tanzakciosAzonosito>46981682-4637-49d2-bd4d-dcfff543742ed</tanzakciosAzonosito>\n"
+ " <erdmeny>HIBAS</eredmeny>\n"
+ " <errorCode>TSH08</errorCode>\n"
+ " <errorMessage>Azonosítószám már hozzá lett rendelve üzleti partnerhez</errorMessage>\n"
+ " </return>\n"
+ " </n0:szemelyKutyaFuleResponse>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}