$re = '/^.+(?=(?:\\\\[^\\\\]+){2}$)/m';
$str = 'C:\\first\\second\\third\\fourth\\fifth\\filename.txt
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);