re = /^.+(?=(?:\\[^\\]+){2}$)/m
str = 'C:\\first\\second\\third\\fourth\\fifth\\filename.txt
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end