package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)\s*rooms?\b`)
var str = `Apartment · 121m² · 4 rooms · 2 parking lots`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}