$re = '/(\d+)\s*rooms?\b/m';
$str = 'Apartment · 121m² · 4 rooms · 2 parking lots';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);