use strict;
my $str = 'testaccount@gmail.com';
my $regex = qr/(?<=.{2}).(?=[^@]*?@)/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";