package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)var\(([a-z\-0-9]+)\)`)
var str = `<div data-color="var(--secondary)" data-color-end="var(--brand-primary)">
<div data-color="var(--secondary-4)" data-color-end="var(--brand-primary-532871)">
<span class="icon icon__centered">
<i class="fal fa-paper-plane" aria-hidden="true"></i>
</span>
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}