import Foundation
let pattern = #"var\(([a-z\-0-9]+)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div data-color="var(--secondary)" data-color-end="var(--brand-primary)">
<div data-color="var(--secondary-4)" data-color-end="var(--brand-primary-532871)">
<span class="icon icon__centered">
<i class="fal fa-paper-plane" aria-hidden="true"></i>
</span>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)