#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)index:\s*([0-9]+)\s*,.+'(\+\+a\+b\+c\+\+)'"
Local $sString = "node v10.15.2 linux/amd64" & @CRLF & _
"" & @CRLF & _
" [ 'b', index: 4, input: '++a+b+c++', groups: undefined ] 'hello'" & @CRLF & _
" [ 'c', index: 6, input: '++a+b+c++', groups: undefined ] 'hello'" & @CRLF & _
" Separating top and bottom so it's easier to read" & @CRLF & _
" [ 'a', index: 2, input: '++a+b+c++', groups: undefined ]" & @CRLF & _
" [ 'b', index: 4, input: '++a+b+c++', groups: undefined ]" & @CRLF & _
" [ 'c', index: 6, input: '++a+b+c++', groups: undefined ]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")