// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)index:\s*([0-9]+)\s*,.+'(\+\+a\+b\+c\+\+)'").unwrap();
let string = "node v10.15.2 linux/amd64
[ 'b', index: 4, input: '++a+b+c++', groups: undefined ] 'hello'
[ 'c', index: 6, input: '++a+b+c++', groups: undefined ] 'hello'
Separating top and bottom so it's easier to read
[ 'a', index: 2, input: '++a+b+c++', groups: undefined ]
[ 'b', index: 4, input: '++a+b+c++', groups: undefined ]
[ 'c', index: 6, input: '++a+b+c++', groups: undefined ]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}