#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^(?:" & @CRLF & _
" (?:[1-9]\d?|1\d{2}|2[01]\d|22[0-3])\. # a group, 1-223 with "."" & @CRLF & _
" (?:(?:[1-9]?\d|1\d{2}|2[0-4]\d|25[0-5])\.){2} # b and c groups 0-255 with "."" & @CRLF & _
" (?:[1-9]?\d|1\d{2}|2[0-4]\d|25[0-5]) # d group, ends with optional netmask instead of "."" & @CRLF & _
" (?:\/(?:[89]|[12]\d|3[0-2]))? # netmask" & @CRLF & _
" ,?\h? # allow comma separated, optional space between" & @CRLF & _
"){1,50}$ # up to 50 IPs"
Local $sString = "1.1.1." & @CRLF & _
"1.1.1.2" & @CRLF & _
"1.1.1.2/23" & @CRLF & _
"1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")