import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\n"
+ " (?:[1-9]\\d?|1\\d{2}|2[01]\\d|22[0-3])\\. # a group, 1-223 with \".\"\n"
+ " (?:(?:[1-9]?\\d|1\\d{2}|2[0-4]\\d|25[0-5])\\.){2} # b and c groups 0-255 with \".\"\n"
+ " (?:[1-9]?\\d|1\\d{2}|2[0-4]\\d|25[0-5]) # d group, ends with optional netmask instead of \".\"\n"
+ " (?:\\/(?:[89]|[12]\\d|3[0-2]))? # netmask\n"
+ " ,?\\h? # allow comma separated, optional space between\n"
+ "){1,50}$ # up to 50 IPs";
final String string = "1.1.1.\n"
+ "1.1.1.2\n"
+ "1.1.1.2/23\n"
+ "1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}