using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"inherits\s+\w+(?:\s*,\s*\w+)*";
string input = @"type MyClass inherits SomeClass,SomeOtherClass implements Node
type MyClass inherits SomeClass, SomeOtherClass implements Node";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}