package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`inherits\s+\w+(?:\s*,\s*\w+)*`)
var str = `type MyClass inherits SomeClass,SomeOtherClass implements Node
type MyClass inherits SomeClass, SomeOtherClass implements Node`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}