$re = '/\d+\s+-.*?(?=\s+-|$)/m';
$str = '"Option 01 - Random phrase - Top Menu
"Option 02 - Another Random Phrase - Su Menu
"Option 03 - More 01 Phrase - Menu
"Option 04 - More Phrase -
"Option 05 - Simple Phrase';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);