#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+\s+-(?:\s.*?(?=\s+-)|.+)"
Local $sString = ""Option 01 - Random phrase - Top Menu" & @CRLF & _
""Option 02 - Another Random Phrase - Su Menu" & @CRLF & _
""Option 03 - More 01 Phrase - Menu" & @CRLF & _
""Option 04 - More Phrase -" & @CRLF & _
""Option 05 - Simple Phrase"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")