import Foundation
let pattern = #"\d+\s+-(?:\s.*?(?=\s+-)|.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"Option 01 - Random phrase - Top Menu
"Option 02 - Another Random Phrase - Su Menu
"Option 03 - More 01 Phrase - Menu
"Option 04 - More Phrase -
"Option 05 - Simple Phrase
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)