using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"( # start capture url
(?:(?:(?:ht|f)tps?\:)\/\/?|(?:www\.)) # start with http or www
(?:\s?[:\w?=%&+-]+ # need some chars in url, allow spaces.
(?:(?:(?:\.)|(?:\/(?:\/)?)))? # can have ., / or // inside urls.
)+ # allow repeat alternating pattern of chars and delimiters
) # end capture url";
string input = @"http://www.apple.com/legal/ privacy/.
abbbbbbbbbbbb
abababab
aaab
hi
h123213i.what
let's do some URLs next segment>
https://duckduckgo.com/?q=perl+regex+%2Fmxsp&t=canonical&atb=v143-1&ia=web, http://www.rexegg.com/regex-modifiers.html
<segment hi there segment> https://duckduckgo.com/?q=tutorial+perl+regex+substitution+capture+groups&t=canonical&atb=v143-1&ia=web-https://regex101.com/, www.giggle.com
B. Privacy Policy. At all times your information will be treated in accordance with Appleās Privacy Policy, which is incorporated by reference into this License and
can be viewed at: http://www.apple.com/legal/ privacy/. qweqweqwewqe
www.howdy.com/welcome::&5";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}