import re
regex = re.compile(r"""
( # start capture url
(?:(?:(?:ht|f)tps?\:)\/\/?|(?:www\.)) # start with http or www
(?:\s?[:\w?=%&+-]+ # need some chars in url, allow spaces.
(?:(?:(?:\.)|(?:\/(?:\/)?)))? # can have ., / or // inside urls.
)+ # allow repeat alternating pattern of chars and delimiters
) # end capture url
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("http://www.apple.com/legal/ privacy/.\n\n"
"abbbbbbbbbbbb\n"
"abababab\n"
"aaab\n"
"hi\n"
"h123213i.what\n\n\n"
"let's do some URLs next segment> \n"
"https://duckduckgo.com/?q=perl+regex+%2Fmxsp&t=canonical&atb=v143-1&ia=web, http://www.rexegg.com/regex-modifiers.html\n"
" <segment hi there segment> https://duckduckgo.com/?q=tutorial+perl+regex+substitution+capture+groups&t=canonical&atb=v143-1&ia=web-https://regex101.com/, www.giggle.com\n\n"
"B. Privacy Policy. At all times your information will be treated in accordance with Appleās Privacy Policy, which is incorporated by reference into this License and \n"
"can be viewed at: http://www.apple.com/legal/ privacy/. qweqweqwewqe\n\n"
"www.howdy.com/welcome::&5")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")