re = /(?<=: |; )([^;]+)/
str = 'тел: +7 (499) 265-58-30; +7 (495) 974-79-22, доб. 6240, 6217; +7 (495) 974-79-22, доб. 6240, 6217'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end