import Foundation
let pattern = #"(?<=: |; )([^;]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"тел: +7 (499) 265-58-30; +7 (495) 974-79-22, доб. 6240, 6217; +7 (495) 974-79-22, доб. 6240, 6217"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)