import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+?)\\s+?(#\\s*?\\(.*?\\)\\s*?)?(\\w+?(?:\\[\\d+?\\])??)\\s*?\\(";
final String string = "second_module #(2) inst2 (.in2(sig2), .out2(sig3));\n\n"
+ " third_module inst3 (.in3(sig3), .out3(sig4));\n\n"
+ " fourth_module #(.in4_clk_freq(50), .in4_rst_val(1'b0)) inst4 (.in4_clk(clk), .in4_rst(rst), .in4_in1(sig4), .in4_in2(sig5), .out4(sig6));";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}