#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[-.\w]+@(?![^.]{0,2}\.[a-zA-Z]{2,}$)([-a-zA-Z0-9]+\.)+[a-zA-Z]{2,}$"
Local $sString = "// Matching" & @CRLF & _
"abc@gmx.dcom" & @CRLF & _
"newemail@gmail.com" & @CRLF & _
"8-d_873@abc.co" & @CRLF & _
"abc.deg@new.co" & @CRLF & _
"abc@9mail.co" & @CRLF & _
"d@mail.com" & @CRLF & _
"abc.deg@new.co.uk" & @CRLF & _
"" & @CRLF & _
"// Not matching" & @CRLF & _
"abc@gmc.d" & @CRLF & _
"abc@gm.de" & @CRLF & _
"d@ma.com" & @CRLF & _
"d@" & @CRLF & _
"9@99.213" & @CRLF & _
"first.name@gmx...de"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")