package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[[^[\]]*]\s*(?:<>|[<>]=|[=><])\s*['"]?\w*['"]?`)
var str = `[household_roster_relationships_topersona_nameadditionalpersono] = "1" OR [household_roster_relationships_topersona_nameadditionalpersono] >= "1" `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}