// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\[[^[\]]*]\s*(?:<>|[<>]=|[=><])\s*['"]?\w*['"]?"#).unwrap();
let string = "[household_roster_relationships_topersona_nameadditionalpersono] = \"1\" OR [household_roster_relationships_topersona_nameadditionalpersono] >= \"1\" ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}