package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bin\b`)
var str = `justin in Rostock
in Rostock
justin in
xx inbal`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}