$re = '/\bin\b/';
$str = 'justin in Rostock
in Rostock
justin in
xx inbal';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);